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Common practices 
The following are some recommended common practices when performing any RF measurement. 

1. Use good quality RF cables.  Double shielded with tin foil is recommended for phase stability 

and isolation. 

2. Use properly power rated RF cables. 

3. Use properly frequency rated connector type. 

a. BNC type is rarely used above 500 MHz sense they do not provide a secure connection.  

Very leaky and repeatability of measurement is difficult.  Avoid using above 100 MHz. 

b. See table below as guidance. ( https://www.arworld.us/resources/Guide-to-RF-Coaxial-

Connectors-and-Cables.asp). 

4. Use correct mating types with connectors and adaptors 

a. See table below as guidance. 

(https://na.support.keysight.com/pna/connectorcare/What_mates_with_what.htm ) 

5. Use a torque wrench as per specification. 

6. Calibration and measurement – let the cables rest in a natural state with no sharp bends. 

a. Secure cables (with tape) to avoid moving them during the calibration/measurement and 

for repeatability. 

7. When making connections, never turn the load by spinning it.  Turn the fitting which will “pull” 

the load in thus “pushing” the center pin into the female load pin.  Spinning the mating will 

damage the center pins of both connections. 

8. Clean all connectors and adaptors with isopropyl alcohol and lint free cloth or swab. 

9. Avoid noisy RF environments when making sensitive measurements that require large 

dynamic ranges. 

 

 

https://www.arworld.us/resources/Guide-to-RF-Coaxial-Connectors-and-Cables.asp
https://www.arworld.us/resources/Guide-to-RF-Coaxial-Connectors-and-Cables.asp
https://na.support.keysight.com/pna/connectorcare/What_mates_with_what.htm
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VNA Pre-set and Calibration file - RF Power off 
When powering ON the unit or using the Pre-set function on the VNA, it is best to set the RF 

power to a default setting of “OFF”.  This is a safety feature to avoid damaging the equipment or 

the device under test.  This also applies to saving calibration files “state and cal data”.  Turn RF 

power off and then save the xxxx.csa file. 

1. Press Power button → Power tab → RF power = off 

2. Press Preset button → Preset Option tab = user → Power ON Option tab = user 

a. User Preset tab = name “state” file and save (name.sta) 

b. Confirm setting: 

i. Turn RF power ON and recall “user preset” state file. 

ii. RF power should be OFF after recall. 

iii. Turn unit OFF and ON. 

iv. RF power should be OFF after unit is turned ON. 

 

Using E-Cal module 
ECal is a new automatic calibration technology for vector network analyzers. Every ECal module 

contains electronic standards that are automatically switched into position during a measurement 

calibration. These electronic standards have been measured at the factory and the data stored 

within the memory of the ECal module. The analyzer uses this stored data, along with the 

measured data, to calculate the error terms for a measurement calibration.  

Setup: 

1. Freq = 490 → 1500 MHZ 

2. # of points = 10001 

3. Power = 0 dBm 

4. IFBW = 100 kHz 

5. Average = off 

6. Smoothing = off 

7. Measure S11 and S21 (magnitude and phase) 
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Connecting E-Cal (N4433A – 4 port 300 KHz to 20 GHz) 

1. Connect the E-cal kit to the VNA via the USB cable.  Wait until the “ready” green light is ON.  

Will automatically detect E-Cal. 

2. Connect RF cables to E-Cal, Port 1-Port 1, etc. 

3. Orientation – Auto (the VNA will automatically detect the orientation of the connections) 

4. Characterization – Factory (will display E-Cal Information) 

5. Press ECal 

1. Select ports to calibrate 

2. Cal Type = SOLT 

3. Press Next – will automatically calibrate 

4. Press Finish 

6. Press Confidence Check (leave ECal connected) 

1. Auto orient and do confidence check = yes 

2. The measurement trace should be superimposed on the Memory trace. 

3. Press Math button – Display Data only (to clear memory trace) 

 

Confidence Check 

 

 

 

 

 

E-Cal Vs Mechanical Calibration Kit 
The following measurements were performed in order to compare results between an E-cal 

module (N4433A Keysight) vs Mechanical kit (F603FE Siglent).  This also verified the parameters 

of the mechanical kit. 

Mechanical Calibration Kit 
A full two port calibration (SOLT) was performed with first using the E-cal module and then using 

the mechanical kit.  The open, short, and thru adaptors from the F603FE mechanical kit were 

measured using both calibration kits and compared. 
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Setup: 

1. Freq = 490 → 1500 MHZ 

2. # of points = 10001 

3. Power = 0 dBm 

4. IFBW = 100 kHz 

5. Average = ON (8) 

6. Smoothing = off 

7. Measure S11 and S21 (magnitude and phase) 

RESULTS:  The “thru” measurement gave the highest delta between measurements with ≈0.50°.  

The phase difference between open and short ≈ 180°.  Not shown are the magnitude results.  In 

both measurement cases, the results were very close to each other with -0.02dB of insertion loss 

for the “thru” adaptor and a return loss of -0.03 dB for “open/short” adaptors. 

Results: 

 
Thru 
(phase °) 

 
Open (phase 
°) 

 
Short (phase 
°) 

 

Freq (MHz) 
Measured 
with E-cal 

Measured 
with 
F603FE 

Measured 
with E-cal 

Measured 
with F603FE 

Measured 
with E-cal 

Measured with 
F603FE 

500 -10.39 -10.14 -11.35 -11.35 168.13 168.45 

600 -12.43 -12.11 -13.71 -13.65 165.85 166.24 

700 -14.48 -14.07 -15.97 -15.89 163.49 163.95 

800 -16.47 -16.06 -18.24 -18.16 161.11 161.68 

900 -18.54 -18.0 -20.6 -20.41 158.71 159.41 

1000 -20.59 -20.05 -22.83 -22.66 156.41 157.12 

1100 -22.59 -22.08 -25.19 -24.96 154.13 154.85 

1200 -24.62 -24.14 -27.38 -27.2 151.75 152.53 

1300 -26.67 -26.17 -29.79 -29.54 149.48 150.31 

1400 -28.72 -28.2 -32.02 -31.76 147.08 147.96 

1500 -30.75 -30.22 -34.34 -34.08 144.79 145.73 

 

10dB attenuator 
A full two port calibration (SOLT) was performed with first using the E-cal module and then using 

the mechanical kit.  A 10 dB attenuator was measured using both calibration kits and compared. 

Setup: 

1. Freq = 490 → 1500 MHZ 

2. # of points = 10001 

3. Power = 0 dBm 

4. IFBW = 100 kHz 

5. Average = ON (8) 

6. Smoothing = off 

7. Measure S11 and S21 (magnitude and phase or unwrapped phase) 

RESULTS:  The largest phase delta was for S11 @ 1.5 GHz of ≈ 2.0° between the two calibration 

kit types. 
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S11 using E-cal for SOLT calibration (atten = open ended) 

 

 

 

 
 

S11 using F603FE for SOLT calibration (atten = open ended) 
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S21 using E-cal for SOLT calibration 

 

 

 

 

 
 

S21 using F603FE for SOLT calibration 
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Low Pass filter 
A full two port calibration (SOLT) was performed with first using the E-cal module and then using 

the mechanical kit.  A low pass filter (Mini-Circuits VLFX-950+) was measured using both 

calibration kits and compared. 

Setup: 

1. Freq = 490 → 1500 MHZ 

2. # of points = 10001 

3. Power = 0 dBm 

4. IFBW = 100 kHz 

5. Average = Off 

6. Smoothing = off 

7. Measure S11 and S21 (Magnitude and phase or unwrapped phase) 

RESULTS:  The largest phase delta was for S11 @ 1.5 GHz of ≈ 1.20° between the two 

calibration kit types. 

 

 

 

 
 

LP filter S-parameters using E-cal module 
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LP filter S-parameters using F603FE cal kit 

 

Loads – 4 port 
A full four port calibration (SOLT) was performed with first using the E-cal module and then using 

the mechanical kit.  Varies loads with approximately 12 dB return loss were connected to each 

port of the VNA . They were measured using both calibration kits and compared. 

Setup: 

1. Freq = 300 → 4500 MHZ 

2. # of points = 20001 

3. Power = 0 dBm 

4. IFBW = 100 kHz 

5. Average = Off 

6. Smoothing = off 

7. Measure S11,S22, S33, and S44 (Magnitude and phase or unwrapped phase) 

RESULTS:  The largest phase delta was for S22 @ 4 GHz of ≈ 2.0° between the two calibration kit 

types.  The largest magnitude delta was for S22 @ 4 GHz of ≈ 0.3 dB° between the two calibration 

kit types. 
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RL magnitude using E-Cal module for calibration 
 
 
 
 

 
 

RL magnitude using Mechanical calibration kit for calibration 
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RL phase using E-Cal module for calibration 
 
 
 

 
 

RL phase using Mechanical calibration kit for calibration 
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S41 magnitude and phase using E-Cal module for calibration 
 
 
 

 
 

S41 magnitude and phase using Mechanical calibration kit for calibration 
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TRL vs E-Cal calibration 
 

The following describes a method for performing a TRL (thru-reflection-line) calibration.  

Measurement results were then compared when using a TRL calibration vs. an E-Cal module 

calibration. 

A full two port calibration (SOLT) was performed by first using an E-cal module (Keysight N4433A) 

and then a TRL calibration.  A band pass filter (Mini-Circuits VBFZ-925-S+) was measured using 

both calibration methods.  Measurements were broken into two parts, broad band rejection and 

band bass. A low power 6dB (two 3dB atten cascaded) attenuator was also measured using both 

calibration techniques. 

For both E-cal and TRL (cal and measurement) – RF cables for both ports were used - N-type to 

SMA m-m. Currently, the SNA5000A supports E-cal with either the N4433A or 85092C modules. 

The DUT is SMA -m-f; thus an SMA f-f adaptor was required.  This adaptor needs to be nulled for 

measured associated with the E-Cal module calibration.  For the measurement associated with the 

TRL calibration, this adaptor is phase matched with the “thru” adaptor used in the TRL calibration.  

It is best to used low loss adaptors or PCB traces for the TRL calibration. 

After performing a E-Cal calibration, connect the SMA-f-f adaptor to the port-2 RF cable and 

perform an “open auto port extension” to null out the adaptor (see Port Extension section).  This is 

only necessary for measuring phase, optional when measuring magnitude. 

 

 
 

TRL kit 
For the TRL calibration, a “line” that is approximately 20° → 160° longer than the “thru” is required 

over the frequency span. If a “line” that is 20 degrees longer at the lower end of the span is used, 

theoretically, a span of 8:1 can be covered (reference microwaves101.com).   

IMPORTAN NOTE:  Same length RF cables were used for port 1 and port 2.  Worst case was a 

difference of 2° @ 4 GHz between RF cables. 
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In this example:  A “line” adaptor which is approximately 0.75” (0.0625 ft) longer was used.  

Approximate dielectric constant = 2.02 (Vf = 0.7), rate is the speed of light in ft/sec, freq = 

500MHz. 

Distance = rate*Vf*time → 0.0625 ft = 983,571,056.433 ft/sec * 0.7 *time 

Time = 90.77 pSec, degrees = time*500MHz*360° = 16.34° 

Based on a 8:1 span, 16.34 ° → 130.72° (approximation) 

The “line” adaptor length was measured using a SOLT E-cal module calibration: -17.52 @ 

500MHz, -34.75° @ 1 GHz and -138.23 @ 4 GHz. 

NOTE:  A “response 1→2” calibration can be performed with the “thru” to null the phase response 

and then measure the “line” adaptor. 

 

Making a Cal kit 
A TRL kit must be defined.  In this example, only an “open” and “thru” are defined.  The “line” was 

described above. 

NOTE:  It was not necessary to define a “thru” standard for the TRL kit, results were the same, this 

procedure is to become familiar with the process of developing a kit.  Refer to other Cal-Kit 

settings for further assistance (F603FE). 

1. Press Cal – Cal tab – Cal kit tab – insert -Connectors tab 

a. Cal kit name = (enter name) , Description = (enter description) 

b. Connector family = select add and name (SMA for this example) 

c. Enter frequency range = 0 to 8 GHz 

d. Gender = Gendered, Impedance = 50 ohm 

2. Standards tab 

a. Gender – referred to the cal-kit and not DUT. 

b. Add = open 

c. Enter label and description 

d. Connector port 1 = SMA male (does not allow for mixed gender, both ports are same 

gender!) 

e. Enter frequency range = 0 to 8 GHz 

f. Delay and open characteristics = 0 (for all entries, except Z = 50 ohms) 

g. Press ok 

h. Add = thru 

i. Enter label and description 

j. Connector = SMA female for both ports 1 & 2 

k. Enter frequency range = 0 to 8 GHz 

l. Delay and open characteristics = 0 (for all entries, except Z = 50 ohms) 

m. Press OK 

3. TRL tab 

a. Calibration kit classes = Reflect 

b. Select OPEN standard >> moves it to right window 

c. Calibration Reference Z0 = System Z0, Test port Ref Plane = thru (for this example) 

d. Calibration kit classes = THRU 

e. Select Thru standard >> moves it to right window 

f. Calibration Reference Z0 = System Z0, Test port Ref Plane = thru (for this example) 

g. Press ok 

4. Press OK again! 

a. The new kit should appear in list of cal-kits. 
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TRL Calibration 
1. Port extensions = off 

2. Two separate calibrations are required – broad and narrow band. 

3. Setup up VNA as described below for broad and narrow band (VNA should be thermally 

stable). 

4. Press Cal button → Cal  Basic Cal → select ports 1 & 2 

5. Cal kit → select custom kit developed above→ DUT (P1 female & P2 male) → Cal type 

(TRL) → next 

6. Select “thru” – connect cables together using a short thru adaptor. 

7. Disconnect cables, leave the “thru” adaptor on the end of port-2 RF cable. 

8. Select “reflect” – open ended 

a. Could also use a short for “reflect” using a custom kit. 

9. Select “line” – use the adaptor that is ≈ 20° longer @ 500 MHz compared to step 6. 

10. Select finish and save calibration. 

NOTE:  For the narrow band calibration a longer “line” adaptor could have been used since the 

upper frequency is 1.3 GHz as opposed to 4 GHz for broad band calibration. 

Verify TRL calibration: 

1. Port extensions – not required, ensure they are off. 

2. Open ended cables with “thru” on port 2, S11 and S22 = 0 dB 

a. S11= -1.10° @ 500 MHz, -2.2° @ 1 GHz, -°4.2@ 2 GHz, -6.0°@ 3 GHz, and - 7.73°@ 4 

GHz 

b. S22= -0.8° @ 500 MHz, -2.2° @ 1 GHz, -°3.95@ 2 GHz, -5.94°@ 3 GHz, and - 7.83°@ 4 

GHz 

3. S21 and S12 = 0 dB (using “thru “ adaptor). 

4. S21 and S12 phase = 0° ± 100m° (using “thru” adaptor). 

5. S21 and S12 phase = -17.52 @ 500 MHz, -34.75° @ 1 GHz, -69.4° @ 2 GHz, -104.0° @  

3 GHz,  and -138.5 @  4GHz (using longer “line” adaptor). 

6. S11 and S22 = <-40 dB (RF cables connected together using both thru adaptors). 

 

E-Cal module calibration 
Connecting E-Cal (N4433A – 4 port 300 KHz to 20 GHz) 

1. Ensure VNA is thermally stable before calibration. 

2. Connect the E-cal kit to the VNA via the USB cable.  Wait until the “ready” green light is ON.  

Will automatically detect E-Cal. 

3. Connect RF cables to E-Cal, Port 1-Port A, etc. 

4. Orientation – Auto (the VNA will automatically detect the orientation of the connections) 

5. Characterization – Factory (will display E-Cal Information) 

6. Press ECal 

1. Select ports to calibrate 

2. Cal Type = SOLT 

3. Press Next – will automatically calibrate 

4. Press Finish 

7. Press Confidence Check (leave ECal connected) 

1. Auto orient and do confidence check = yes 

2. The measurement trace should be superimposed on the Memory trace. 

3. Press Math button – Display Data only (to clear memory trace) 
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BP filter - broad band setup-measurement 
Setup (broad band): 

1. Freq = 495 → 4050MHZ (factor of ≈ 8) 

2. # of points = 20001 

3. Power = 0 dBm 

4. IFBW = 200 kHz 

5. Average = Off 

6. Smoothing = Off 

7. Measure S11 and S21 (Magnitude) 

8. Windows = 2 

NOTE:  Port extensions is not necessary for magnitude measurements. 

 

Results: 

 
 

BP Filter S11 and S21 using E-cal module calibration 
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BP Filter S11 and S21 using TRL calibration 
 

BP filter - narrow band setup-measurement 
Setup (narrow band): 

1. Freq = 700 → 1300 MHZ  

2. # of points = 10001 

3. Power = 0 dBm 

4. IFBW = 100 kHz 

5. Average = Off 

6. Smoothing = ON (2% for GD measurement) 

7. Measure S11,S22, and S21 (Magnitude, phase or unwrapped phase, and group delay) 

8. Windows = 3 or 4 

For E-Calibration: 

1. After performing SOLT with the E-Cal module. 

2. Connect the phase matched SMA f-f adaptor from the “thru” TRL calibration to port 2 RF 

cable. 

a. It can be any adaptor of any length; this method is just to keep “things” consistent! 

3. Perform an open auto port extension on port 2. 

a. Connect the cables together via the adaptor. 

b. Measure S21 phase, should be 0 dB and 0 °± 200m°, if needed, fine tune the “port 

extension time”.   

c. In this example: Port 2 = 82 pS (extension) 

d. S11 = 0 dB with -2.2° @ 750 MHz, -3.05° @ 1 GHz, and -3.74 @ 1.25 GHz° 

e. S22 = 0 dB with -1.0° @ 750 MHz, -1.3° @ 1 GHz, and -1.56 @ 1.25 GHz° 

 

NOTE:  Ensure the phase matched “thru” SMA-f-f is in place during all phase measurements.  This 

adaptor is the one used during the “thru” TRL calibration shown in the snap shot above.  S11 and 

S22 phase results have a slight difference since the fringing capacitance at port 1 is not nulled. 
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S21 phase was nulled across the band so the results should match using both calibration 

techniques.  

Results: E-cal module calibration measurements has the “thru” matching adaptor used during the 

TRL calibration.  The TRL has the “thru” adaptor during all measurements. 

 

 
 

BP Filter S11/ S22 magnitude and phase using E-cal module calibration  
 

 

BP Filter S11/ S22 magnitude and phase using TRL module calibration 
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BP Filter S21, magnitude, phase, and GD using E-cal module calibration 

 

 

 
 

BP Filter S21, magnitude, phase, and GD using TRL calibration 
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6dB Attenuator – broad band 
Setup (broad band): 

1. Freq = 495 → 4050 MHZ (factor of ≈ 8) 

2. # of points = 20001 

3. Power = 0 dBm 

4. IFBW = 200 kHz 

5. Average = Off 

6. Smoothing = Off 

7. Measure S11 (magnitude and phase with DUT open ended) 

8. Measure S21 (Magnitude and phase or phase unwrapped) 

9. Windows = 2 

10. DUT  = 6 dB atten, SMA m-f, 

NOTE:  E-cal module port extensions is necessary for absolute phase measurements. 

For E-Calibration: 

1. After performing SOLT with the E-Cal module. 

2. Connect the phase matched SMA f-f adaptor from the “thru” TRL calibration to port 2 RF 

cable. 

a. It can be any adaptor of any length; this method is just to keep “things” consistent! 

3. Perform an open auto port extension on port 2. 

a. Connect the cables together via the adaptor. 

b. Measure S21 phase, should be 0dB and 0 °± 200m°, if needed, fine tune the “port 

extension time”.   

c. In this example: Port 2 = 81.7 pS (extension) 

d. S11 = 0 dB with -1.37° @ 500 MHz, -6.4° @ 2 GHz, and -13.15 @ 4 GHz° 

e. S22 = 0 dB with -0.5° @ 500 MHz, -2.16° @ 2 GHz, and -1.61 @ 4 GHz° 

NOTE:  Ensure the phase matched “thru” SMA-f-f is in place during all phase measurements.  This 

adaptor is the one used during the “thru” TRL calibration shown in the snap shot above.  S11 and 

S22 phase results have a slight difference since the fringing capacitance at port 1 is not nulled. 

S21 phase was nulled across the band so the results should match using both calibration 

techniques.  

Results: E-cal module calibration measurements has the “thru” matching adaptor used during the 

TRL calibration.  The TRL has the “thru” adaptor during all measurements. 

Results: 
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Attenuator S11, magnitude & phase, using E-cal module calibration 

 

 
 

Attenuator S21, magnitude & phase, using E-cal module calibration 
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Attenuator S11, magnitude & phase, using TRL calibration 

 

 
 

Attenuator S21, magnitude & phase, using TRL calibration 
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TRL - measuring mechanical calibration kit 
The following measurements were conducted to ensure that a TRL calibration will produce a 

measurement result of 180° between an open/short.  The open/short were from the F603FE 

mechanical kit. 

Perform a TRL calibration – see TRL calibration/verify section. 
 
Setup (broad band): 

1. Freq = 495 → 4050 MHZ (factor of ≈ 8) 

2. # of points = 20001 

3. Power = 0 dBm 

4. IFBW = 200 kHz 

5. Average = Off 

6. Smoothing = Off 

7. Measure S11 (magnitude and phase) 

8. Windows = 1 

9. DUT  = open, short, and 50Ω load from F603FE cal-kit. 

NOTE:  No auto port extensions. 

Results: 

 50Ω 
Open (phase 
°) 

 
Short (phase 
°) 

 

Freq (MHz) 
Measured 
with TRL 
calibration 

Measured with 
E-cal 

Measured with 
TRL calibration 

Measured 
with E-cal 

Measured with 
TRL calibration 

500 -36.0 -11.35 -11.08 168.13 168.3 

600 -35.8 -13.71 -13.42 165.85 116.0 

700 -36.7 -15.97 -15.61 163.49 163.75 

800 -36.9 -18.24 -17.87 161.11 161.2 

900 -37.05 -20.6 -20.18 158.71 158.63 

1000 -37.01 -22.83 -22.24 156.41 156.65 

1100 -37.4 -25.19 -24.62 154.13 154.33 

1200 -38.15 -27.38 -26.65 151.75 151.92 

1300 -38.1 -29.79 -28.9 149.48 149.75 

1400 -38.01 -32.02 -31.04 147.08 147.47 

1500 -37.9 -34.34 -33.25 144.79 145.25 

2000 -38.2 Not measured -44.03 Not measured 133.9 

3000 -37.3 Not measured -65.58 Not measured 111.57 

4000 -32.8 Not measured -86.91 Not measured 88.7 
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Phase Matched Adaptors 

 

Phase Matched 
Phase matched adaptors are useful when the gender of DUT matches the gender of the “thru” 

calibration adaptor (mechanical kit).  For some mechanical calibration kits or when performing a 

simple “response” calibration, the “thru” calibration adaptor is required to be in place during an 

“absolute” phase measurement otherwise the phase will be incorrect.  This procedure assists in 

finding matched adapters that can be used during the DUT measurement.  In essence, finding an 

adapter that matches the phase of the “thru” calibration adaptor or matching phase response of 

two mixed gender adaptors or RF cables.  Phase matched adaptors can be expensive.  This 

usually is not a problem with E-cal kits. 

If after completing the calibration and the phase response of the “thru” adaptor displays 0°, a 

matched adaptor or the calibration “thru” adaptor will have to be in place during a DUT absolute 

phase measurement. 

NOTE:  For Siglent calibration kits, the thru adaptor is compensated for during a 

SOLT/SOLR calibration.  The adaptor should not to be in place during an absolute  

phase measurement. 

In order for cables or adaptors to be considered phase matched, the phase must be 

equal at multiple frequency points which indicates that they have the same group 

delay. 

 

NOTE:  In this example, a phase response calibration was performed, thus, a phase matched F-M 

adaptor is needed to replace the F-F adaptor used during the “thru” calibration for an absolute 

phase measurement.  This is not critical when making relative measurements.  Relative phase 

measurement is equivalent to saying these two pieces of wood are cut to equal lengths, yet you 

don’t know what the exact (absolute) length is. 
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The above setup will provide an absolute phase measurement.  The f-m adaptor replaces the f-f 

adaptor used during calibration. 

 

Measuring phase of f-f SMA calibration (or any) adaptor 
In order to improve phase stability, an N-type male to SMA-male adaptor is connected to port 1 of 

the VNA.  For this example, we will measure an f-m SMA adaptor and compare the phase to the f-f 

SMA adaptor that is supplied with the F603FE calibration kit.  

 

Calibration Setup 
1. Press Preset (if unknown state) 

2. Connect m-m N-type to SMA adaptor on port 1 

3. See calibration procedure for further assistance. 

4. IF BW = 100 kHz, # of points = 3201, Power = 0 dBm, Fc=900 MHz, Span = 220 MHz 

5. Display → Window setup → add window → Measure S11 (phase and Smith Chart)   

6. Markers = 800, 900, & 1000 MHz 

7. Ensure port extensions are OFF (Port Ext = OFF, Math = OFF). 

8. Perform a “port 1” open, short, load calibration 

a. Select cal kit (F603FE), DUT connector (female), Cal type (OSL) 

b. Turn averaging ON=8 

9. Verify - with no adaptors connected, open ended, result will display approximately ≈ -2.1° @ 

900 MHz.  This is the “fringing” capacitance of the extended center pin and is normal. 

NOTE:  The average of the fringing capacitance can be included. If a port extension is performed, 

the phase will be 0°.  Thus ,we can subtract the average with no port extension performed when 

measuring.  Example:  S11 phase measurement = -°40, fringing = -2.1°, Result = (40 - -2.1 / 2) /2 

= -19.475°.  This is basically the average of the measurement with no port extension and auto port 

extension performed. 
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S11 phase response of M-M N-type to SMA adaptor after calibration (open ended) 

 

 

Procedure and results 
1. Leave the male end of the m-m N to SMA adaptor at port 1 open (no load). 

2. Connect f-f SMA thru adaptor from the calibration kit or any f-f  SMA adaptor/RF cable. 

a. Record all marker values (-37.78° @ 900 MHz divide by two for the round trip), = -18.89°). 

i. This is the phase length of the f-f SMA cal-kit adaptor which does not match the 

results of a SOLT calibration with the thru adaptor in place (see Mechanical 

Calibration Kit section  page 6). 

b. Compensate for fringing  

i. @ 900 MHz:  (-37.78 - -2.1/2) / 2 = -18.365°  

ii. @ 1 GHz (-41.99 - - 2.37/2) / 2 = -20.4025° 

c. average measurement is closer to the results in the table (page 6) 

NOTE:  This is an alternate method, performing a SOLT or SOLR will give the same result since 

Siglent cal-kit knows the phase response of the thru adaptor.  Any f-f SMA adaptor can be inserted 

without the “thru” calibration adaptor in place.  The result is absolute phase. 
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f-f SMA F603FE cal kit adaptor measurement (with calibration fringing) 

 

 

 

 

Measuring phase of a f-m SMA adaptor 
The recommended way to perform this measurement is to perform a “response” calibration and 

then insert the f-m adaptor with the f-f thru adaptor in place. 

 

 

 

 

Calibration Setup 
1. Press Preset (if unknown state) 

2. Connect m-m N-type to SMA RF cables to port 1 and port 2. 

3. See calibration procedure for further assistance. 

4. IF BW = 100 kHz, # of points = 3201, Power = 0dBm, Fc=900 MHz, Span = 200 MHz 

5. Display → Window setup → add window → Measure S21 (magnitude and phase)   

6. Markers = 820, 900, 920, 950, & 980 MHz 

7. Ensure port extensions are OFF (Port Ext = OFF, Math = OFF). 

8. Perform a “response port 1 →2” calibration 

a. Select cal kit (F603FE), DUT connector (female), response 

b. Turn averaging ON=16 

9. Verify – Magnitude and phase should be 0dB and 0° and flat across the band. 
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Procedure and results 
1. Disconnect RF cables and insert DUT with the thru calibration adaptor in place. 

2. Save measurement. 

 

f-m SMA adaptor phase response 

 

 

 

Measuring phase of a m-m SMA adaptor or RF cable 
The recommended way to perform this measurement is to perform a full SOLT/SOLR calibration 

and subtract out the f-f adaptors. 

 

 

 

Calibration Setup 
1. Press Preset (if unknown state) 

2. Connect m-m N-type to SMA RF cables to port 1 and port 2. 

3. See calibration procedure for further assistance. 

4. IF BW = 100 kHz, # of points = 3201, Power = 0 dBm, Fc=900 MHz, Span = 200 MHz 

5. Display → Window setup → add window → Measure S21 (magnitude and phase)   

6. Markers = 820, 900, 920, 950, & 980 MHz 

7. Ensure port extensions are OFF (Port Ext = OFF, Math = OFF). 

8. Perform an SOLT calibration. 

a. Select cal kit (F603FE) 

b. Turn averaging ON=16  

9. Verify – S21 Magnitude and phase calibration – see below. 
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Phase response of F603FE cal-kit thru adaptor 

 

 

Procedure and results 
1. Measure the insertion phase of a f-f thru adaptor and record the values. To preserve the kit, 

avoid using cal-kit parts during measurements. 

a. Remove the 1st adaptor and insert a 2nd  f-f thru adaptor and record the values. 

b. Insert DUT and both f-f thru adaptors and record the values. 

c. Measurement format - Phase unwrap if needed 

d. Subtract the phase and magnitude of both thru adaptors from Step b measurement. 

i. Insertion phase of the RF cable (@ 950 MHZ: -327.18° + 27.91° + 27.65° = -271.62°) 

 

1st adaptor f-f SMA adaptor phase response 
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2nd adaptor f-f SMA adaptor phase response 

 

 

 

 

RF cable with both f-f SMA adaptors - phase response 
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Parameters to consider for calibration and measurement 
Calibration and Measurement 

1. Gain and Power - Anticipate the gain(data sheet of DUT) and ensure the maximum Pout of 

DUT does not exceed the damage threshold of the test equipment.  Try to keep the power 

going into any port to <+10dBm. If there is a possibility of potentially damaging the equipment, 

place an external attenuator at the VNA’s receiving port – see example on measuring P1dB. 

a. Pout(dBm) = Pin(dBm) + Gain(dB)  

2. Frequency of interest. 

a. For measuring filters, it is sometimes best if the span is broken up into two bands, the 

band pass and the full span which includes the rejection band. 

3. Number of points – affects resolution of measurement, GD measurement, and measurement 

speed. 

4. IF bandwidth - affects equipment noise floor (dynamic range), measurement speed, and group 

delay measurement (elevated noise floor = 10*log(BW/1Hz) or BW = 100 has two zeros, the 

noise floor increases by 20 dB, 10k = 40 dB). 

5. Power level – affects equipment noise floor (dynamic range) 

a. Caution must be taken not to overdrive device under test (DUT) or damaging test 

equipment such as when measuring the gain of a power amplifier. 

6. Using “smoothing” or “averaging” traces for noisy measurements. 

a. Smoothing averages multiple nearby measuring points based on aperture percentage. 

b. Averaging takes multiple frequency sweeps and averages the sweeps/traces.  

7. Determine amplitude dynamic range required such as when measuring the pass band and 

rejection band of a filter.  This can be verified after calibration by connecting the ports together 

and disconnecting the cables under an S21 or S12 measurement. 

a. Connected - should read 0dB 

b. Disconnected – should read <-dB than expected measurement. 

c. Smoothing or averaging may be needed. 

d. During the “thru” calibration, isolation calibration may be required.  This “nulls” the cross 

talk between the internal ports of the equipment.  It is usually performed by 

disconnecting the RF cables and terminating the end points with the reference 

impedance (50Ω). 

8. Measuring phase and group delay. 

a. Sufficient measurement resolution is required to avoid phase wrapping - measuring two 

points that are greater than 180°.  For a larger group delay a smaller frequency step size 

is required. 

b. 𝐼𝐹 𝐵𝑊 = 2 ∗ ∆𝑓 

c. 𝑁𝑢𝑚𝑏𝑒𝑟 𝑜𝑓 𝑝𝑜𝑖𝑛𝑡𝑠 = ((𝑆𝑝𝑎𝑛 ÷  ∆𝑓) − 1), 𝑝𝑜𝑖𝑛𝑡𝑠 > 2  

d. 𝐺𝑟𝑜𝑢𝑝 𝐷𝑒𝑙𝑎𝑦 (𝑠𝑙𝑜𝑝𝑒) =  −∆∅ ÷ (360° × ∆𝑓), where ∆∅ < 180°  
e. Example for minimum settings 

i. Assume a Fc= 1GHz and a span of 100MHz with an anticipated group delay of 6nS 

for a 4-foot RF cable. 

1. 6nS = 180°/(360°*Δf), Δf = 83.3MHz (step size) 

2. 𝐼𝐹 𝐵𝑊 = 2 ∗ ∆𝑓, 𝐼𝐹 𝐵𝑊 = 166.6𝑀𝐻𝑧  
3. Minimum number of points, = 100MHz/83.3MHz = 2 

4. These are not very practical settings.  The noise floor of the equipment will be 

elevated due to the high IF BW. 

ii. Alternate method: 

1. Assume phase resolution of ∆∅ = 0.1° , and GD ≈ 6nS. 

2. ∆𝑓 =
0.1°

360∗6𝑛𝑆
= 46.3𝑘𝐻𝑧,  with an IF BW = 92.6kHz (set to 100kHz) 
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3. # 𝑜𝑓 𝑝𝑜𝑖𝑛𝑡𝑠 = 100𝑀𝐻𝑧/46.3𝑘𝐻𝑧 + 1 =

2161 𝑤ℎ𝑖𝑐ℎ 𝑚𝑒𝑎𝑛𝑠 2 𝑚𝑒𝑎𝑠𝑢𝑟𝑒𝑚𝑒𝑛𝑡𝑠 𝑎𝑟𝑒 𝑡𝑎𝑘𝑒𝑛 𝑒𝑣𝑒𝑟𝑦 92.6𝑘𝐻𝑧(100𝑘𝐻𝑧).  
4. You can reduce the IF BW and maintain 2161 points to reduce the noise floor 

while maintaining phase and GD accuracy. 

5. You can also do the following: 

a. Or # of points = 3201, IF BW = 10kHz (under sample), phase and GD 

measurement will remain accurate since the maximum step size is 

83MHz for 6nS group delay. 

b. Step size = 100MHz / 3201 = 32.2kHz.  Some information is lost since the 

IF BW < freq step size, but for some “weakly non-linear” functions, under 

sampling may be sufficient. It is a compromise of measurement speed, 

lower noise floor, and accuracy. 

f. NOTE:  When measuring phase, GD, or phase linearity, if the results are in doubt, 

increase/decrease the number of points and verify results do not vary.  Adjust and 

recalibrate as needed.  Do this while displaying GD and phase without using 

“unwrap” phase option. 

9. Measuring Phase Linearity 

a. Phase linearity is defined as the deviation from a constant phase slope across a 

frequency span.  This is the same as the difference in group delay between the two 

points.  It is usually referenced to the center frequency point of the measurement.   

i. Example: 

1. Assume GD1 = 4nS, GD2 = 4.1nS, Span = 100MHz 

2. Phase deviation = |(GD2 – GD1)|*360°*100MHz = 3.6° 

3. The DUT has a deviation of 3.6° from a constant slope over a 100MHz span. 

 

 

 

Port Extensions 
1. This extends the calibration reference plane to a new refence plane for return loss 

measurements. 

2. This may be useful in de-embedding RF traces, connectors, or lumped components from a 

DUT.  Helpful in determining matching networks or when a cable is added after calibration. 

3. On the DUT, break the point where the new reference point will be. 

i. Provide a “short” or “open” at the new reference point on DUT. 

ii. Perform an initial calibration – see calibration section. 

iii. Press Cal button → Port extension → Port Extensions → Reset → Auto Port Extension 

i. Ensure “Reset”. 

ii. Configuration - select ports 

iii. Setting – include loss, adjust for mismatch if desired (if unchecked, return loss will 

display 0dB after completing port extension). 

iv. Method – current span 

v. Velocity factor = 1 (not critical unless accurate “distance” is required.  The value for a 

polyethylene dielectric cable is 0.66 and PTFE dielectric cable is 0.7.) 

iv. Next → Measure (select either open or short) → Finish 

v. Ensure port extension is ON (will display time, distance, and DC loss) 

vi. Verify using Format → Smith or Magnitude or Phase 

i. For and “open” extension → Mag = 0db, Phase = 0° (flat line across the span) 

ii. Smith Chart – a “dot” on the right side. 
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Measuring Phase Linearity 
The following describes two methods of measuring phase linearity across a desired frequency 

band.  Phase linearity is the phase deviation from a constant slope or also the change in group 

delay across the frequency band. Usually referenced to a center marker. 

Manual delay entry 
1. Phase Linearity – manually enter delay 

a. Setup VNA and perform a response calibration or full calibration. 

b. Set up two traces – S21 or S12 = Phase (or unwrapped phase) and group delay 

c. Insert DUT. 

d. Scale accordingly. 

e. Note the minimum delay time on GD trace (averaging may help or smoothing). 

f. Use Format 2 →unwrap phase (better resolution on phase non-linearity). 

g. Place a marker at the minimum GD point and markers at points of interest. 

h. On phase trace: 

i. Scale → Electrical Delay – enter delay time from the GD reference marker. 

ii. Electrical Delay for GD trace remains at 0 Sec. 

iii. Velocity factor is not critical for this measurement unless measuring distance 

(distance = C*Vf*time, C = free space speed of light). 

iv. Scale phase trace  

NOTE:  This is the non-linear phase performance across the band of interest– deviation from a 

constant slope.   Typically, as gain/loss changes, there is also a change in phase such a with 

filters.  Non-linear phase response may be undesirable such as with linear frequency modulated 

chirps. 

 

Marker Delay Function – auto TBD 

 

 

Verify Equipment stability 
This procedure assists in verifying equipment, RF cables, and adapters are stable prior to 

calibration and measurement. 

Number of points and IF BW is not critical for this procedure since we are only concern about 

verifying stability.  The settings are suggested in preparation for measuring a low power amplifier 

and should suffice for verifying stability.  For a true device measurement, settings will vary.  

1. Measure S21 (magnitude and phase) 

2. Set up VNA – will use same settings for measuring DUT in the next section. 

a. Allow at least 30 minutes of warm-up time for VNA. 

b. Press → Preset (if at unknown state) 

c. Press Power button → Power Level = -10dBm  

d. Press Frequency button → Start Stop Freq =  900MHz to 1GHz  

e. Press AVG/BW button → IF Bandwidth = 20kHz (43dB elevated noise floor) 

i. Averaging and Smoothing = Off (equipment noise floor is low enough and is not a 

very sensitive measurement) 

f. Press Sweep button → Number of points = 1601 → Sweep mode = auto  

i. Measures every 62.5kHz and is under sampling since IF BW < step size. Not critical 

at this point 

ii. Ensure the VNA is temperature stable, important for phase measurements. 
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1. Set up VNA as detailed above. 

2. Before doing a full calibration. 

a. Press Display button → Add Trace → New Trace + Window 

b. Press Meas button → S21 for top and bottom trace 

c. Press Format button → top trace → Log Mag → bottom trace → phase 

d. Press Scale button → top trace→scale = .5dB/div, ref level = 0dB→ bottom trace = 1°/div, 

ref level =0° 

3. Press Marker button →  

a. Marker Setup → Coupled = all 

b. Marker → add markers and set desired frequency. 

4. Connect VNA ports together Port 1 to Port 2 using desired cables and a thru adaptor. 

a. Ensure ports and RF cable connectors are clean. 

b. Use torque specifications for connectors. 

c. Let the cables rest in a “natural” state with no sharp bends during calibration and 

measurement. Do not handle the cables during calibration! 

5. Press Cal button → Basic Cal   

a. Check ports 1 & 2 

b. Cal kit = select any kit, not important at this point. 

c. DUT Connector = gender is not important at this point. 

d. Cal Type = Response (thru) 1 → 2 

e. Select “Next” and press “thru”. 

i. No need to select “isolation” since the noise floor is well below the expected 

measurement results. 

ii. Press Finish tab and Save calibration 

iii. Save Recall button → Save State→Save Type→State + Cal Data → Save State 

(name file). 

f. Results:  Both traces should show 0dB and 0° respectively. 

g. Optional: Save traces 

i. Press Math button → Select trace → Data Memory→ Display Data and Memory 

h. Gently move RF cables and let them rest, ensure results did not vary from calibration 

results. 

i. Disconnect “thru adaptor”  and reconnect. Ensure results did not vary from calibration 

results. 

i. After disconnecting and reconnecting cables, it is normal for the results to vary by a 

few hundredths/dB for magnitude and a few tenths/degrees for phase.  The results 

should still be a flat line for both traces. 

j. If results did not vary, equipment and RF cables are stable. 

6. If results varied, possible culprits: 

i. If equipment has not reached temperature stability, phase will move up or down at a 

constant rate but will maintain a flat line.  

ii. If there are abrupt changes, connectors could be dirty, loose during calibration, or bad 

cables (frayed outer shield usually near connector) . 

iii. During calibration, when calibrating the open, short, and thru, the response on the screen 

should be a flat line, if not, measurements will be questionable. 

iv. Doubled shielded cables with a solid foil have better performance than single shielded 

cables. 

v. The “thru” standard may be damaged.  Try another adaptor. 

vi. Noisy RF environment – WiFi, Laptops, noisy equipment nearby – Spectrum analyzer, RF 

generator, etc.  
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Normal performance of cables being disconnect/reconnected after calibration (response 

calibration) 

 

 

Setup for measuring S-parameters and calibration 
The following procedure is for measuring a low power amplifier; however, the procedure is similar 

when measuring most devices. 

1. Measure S11, S22, S21, & S12 (will measure magnitude, phase, group delay, and phase 

linearity) 

2. DUT = Mini Circuits GVA-62+ 

3. Parameters: 

a. V = 5V, I = 81mA 

b. G ≈ 15.6dB, P1dB  ≈ 19.6dBm (output compression point) 

c. S11 ≈ -13dB, S22 ≈ -19dB, S12 ≈ -21dB 

d. Anticipated GD < 10nS (based on experience) 
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4. Set up VNA 

a. Allow at least 30 minutes of warm-up time for VNA. 

b. Press → Preset (if at unknown state) 

c. Press Power button → Power Level =-10dBm  (ensures port 2 <+10dBm) 

d. Press Frequency button → Start Stop Freq =  900MHz to 1GHz  

e. Press AVG/BW button → IF Bandwidth = 20kHz 

f. Averaging and Smoothing = Off (equipment noise floor is low enough and is not a very 

sensitive measurement) 

g. Press Sweep button → Number of points = 1601 → Sweep mode = auto (measures every 

62.5kHz but less than the maximum step size for measuring phase and GD). 

i. We are under sampling with IF=20kHz & 1601 points.  These settings will suffice for 

this measurement.  It is a compromise of measurement speed, lower noise floor, and 

accuracy (we would need 10001 points for a step size of 10kHz). 

h. Example - assume 2nS for GD, maximum step size ∆𝑓 =
180°

360∗2𝑛𝑆
, = 250𝑀𝐻𝑧 step size. 

i. Before doing a full calibration. 

i. Press Display button → Add Trace → New Trace + Window 

ii. Press Meas button → S-parameters → S21 for top and bottom trace 

iii. Press Format button → top trace → Log Mag → bottom trace → phase 

iv. Press Scale button → top trace→scale = .5dB/div, ref level = 0dB→ bottom trace = 

1°/div, ref level =0° 

v. Press Marker button →  

1. Marker Setup → Coupled = all 

2. Marker → add markers at desired frequency. 

vi. Press Cal button → Basic Cal (ensure Port Extensions are OFF)  

1. Check ports 1 & 2 

2. Cal kit = select calibration kit (mechanical kit F603FE for this example). 

3. DUT Connector = check appropriate genders for device under test (female for 

this example). 

a. Ensure ports and RF cable connectors are clean. 

b. Use torque specifications for connectors. 

c. Let the cables rest in a “natural” state with no sharp bends during 

calibration and measurement.  Do not handle the cables during calibration! 

4. Cal Type = SOLT (short, open, 50Ω  load, & thru) 

5. NOTE:  Depending on cal-kit and the gender that was selected, Cal Type 

options will be limited. 

6. Select “Next”  

a. Connect the appropriate calibration load from kit to the calibration 

reference point and then press the appropriate tab (open, short, 50Ω load, 

& thru) 

b. No need to select “isolation” since the noise floor is well below the 

expected measurement results for all S-parameters. If isolation is selected, 

disconnect cables and terminate with 50Ω loads. 

c. Press Finish tab and Save calibration 

i. Save→State→Save Type→State and Cal Data→Save State as (name 

file) 
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Verify Calibration 
The following is for verifying calibration. 

1. As a minimum do the following to verify calibration from previous steps. 

2. Connect RF cables together using the cal-kit “thru” adaptor. 

a. On Top trace: 

i. Press Meas button → S-parameters  → 

1. Result:  S21 & S12 Magnitude format should be 0 dB, flat trace. 

2. Result: S11 & S22 Magnitude format should be better than <-40 dB.  Typical 

performance is <-50, dependent on frequency range and quality of RF cables. 

3. Typically, the calibration reading should be <-20 dB better than the expected 

measurement. 

b. On bottom trace: 

i. Press Meas button → S-parameters  → 

1. Result: S21 & S12 Phase response will not display 0°,it will display the insertion 

phase of the thru cal-kit adaptor.  If the DUT is the same gender as the adaptor, a 

phase matched adaptor will not be necessary.  The result will be the absolute 

phase of the DUT. 

2. See below.  

3. Refer to the section on how to verify equipment and RF cable stability. 

4. Further calibration verification. 

a. Disconnect RF cables and remove any loads or adaptors. 

i. On Top trace: 

ii. Press Meas button → S-parameters  → 

1. Result:  S11 & S22 Magnitude format should be 0 dB, flat trace. 

iii. On bottom trace: 

iv. Press Meas button → S-parameters  → 

1. Result: Since the span is relatively small, S11 & S22 Phase format should be ≈       

-2.9°, flat trace. S11 and S22 results should be very close to each other at each 

frequency point. 

2. This is the “fringing” capacitance of the center pin. 

b. Alternate connecting the open and short loads from the cal-kit to each cable. 

i. Press Meas button → S-parameters  → 

1. Result: Open and Short load,  S11 & S22 Magnitude format should be 0dB, flat 

trace. 

2. Result: Open load S11 & S22 Phase format should be ≈ -21.5° which is the right 

side of the Smith chart. Results should match and have a flat trace. 

3. Result: Short load  S11 & S22 Phase format should be ≈ +158.5° which is the left 

side of the Smith chart. Results should match and have a flat trace.  

4. The reason for the phase shift is due to the frequency dependent nth  order 

capacitance (open load) and nth order inductance (short load) polynomial (example 

C = C1 + C2*f + C3*f^2 +…….) (example L = L1 + L2*f + L3*f^2 +…….) 

a. What is important is that the magnitude for S11 & S22 should be 0dB and the 

phase delta between open and short is 180°. 

c. Alternate connecting the 50 Ω load from the cal-kit to each cable. 

i. On Top trace: 

ii. Press Meas button → S-parameters  → 

1. Result: S11 & S22 Magnitude format should be better than <-40 dB.  Typical 

performance is <-50, dependent on frequency range and quality of RF cables (a 

dot in the middle of the Smith chart). 
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d. Reconnect RF cables with the cal-kit thru and verify S21 & S12 magnitude and 

phase. 

Hint:  Use a known 10 dB attenuator load to verify S11, S22, S12 & S21 accuracy.  The S11/S22 

magnitude should be -20 dB (return loss) with an open or a short at the output port of the 

attenuator and -10 dB (insertion loss). This is dependent on the quality of the attenuator, use this 

as a sanity check!   

 

Typical phase response of F603FE cal-kit thru adaptor 

 

 

 

Typical phase response of “open” load F603FE cal-kit  
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Typical phase response of “short” load F603FE cal-kit  

 

Measure GVA-62 low power amplifier 
The following procedure is for measuring  S-parameters of GVA-62 Evaluation Board . 

1. Please do not connect DUT just yet! 

2. Set up VNA as described in previous steps above. 

3. IF BW = 20 kHz, # of points = 1601, Power = -10 dBm, Span = 100 MHz (step size = 62.5 

kHz) 

a. Under sampling since step size > IF BW. 

b. Step size is still small enough for the anticipated group delay. 

4. Measure S11, S22, S21, & S12 (magnitude, phase, group delay, and phase linearity) 

5. Parameters @ 1 GHz (from data sheet): 

a. V = 5V, I = 81mA 

b. S21 ≈ +15.6 dB, P1dB  ≈ 19.6 dBm (output compression point) 

c. S11 ≈ -13 dB, S22 ≈ -19 dB, S12 ≈ -21 dB 

d. Anticipated GD < 10nS (based on experience) 

 

Magnitude measurement 
1. Magnitude - Setup four traces. 

a. Press Display button → Add Trace → New Trace + Window 

b. Measure magnitude S11, S22, S21 & S12 and scale accordingly. 

c. Press Power button → RF Power Off, ensure it is set to -10 dBm. 

i. Connect DUT (voltage off) 

ii. Apply voltage (for safety, if possible, voltage/current limit power supply)  

iii. Turn RF power On. 

iv. Results – see below. 
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GD and Phase measurement 
1. GD and Phase - Setup two traces. 

a. Turn RF power Off. 

b. Delete two traces. 

c. Measure phase and group delay S21 and scale accordingly. 

d. Group delay top trace – Smoothing ON @ 25 smoothing points . 

e. Scale = 1 nS/div 

f. Turn RF power ON, ensure it is set to -10dBm. 

g. Adjust “Number of Points” and verify measurement is constant. 

i. As the number of points is adjusted, an “*” will appear at the bottom of screen. 

ii. C 2-port to C*2-port indicating a change from the calibration parameters. 

iii. GD is a noisy measurement specifically when measuring pico-Seconds. 

 

 

 

 

 

Magnitude (S11, S22, S21, & S12) 
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GD and Phase (S21) 

 

 

 

GVA-62+ data sheet 
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Setup for measuring output compression point (P1db) 
The following procedure is for measuring compression point, Pin Vs (S11, Gain, and Phase). This 

determines the gain and phase linearity performance of the amplifier and is helpful in determining 

error vector magnitude performance. 

1. Parameters (from data sheet): 

a. V = 5V, I = 81mA 

b. S21 ≈ +15.6 dB, P1dB  ≈ 19.6 dBm (output compression point) 

c. S11 ≈ -13 dB, S22 ≈ -19 dB, S12 ≈ -21 dB 

2. Set up VNA as follows: 

a. IF BW = 20kHz, # of points = 201 

b. Press Sweep button → Sweep type = Power sweep   

i. Press Power button → Power → Start power = -10dBm, Stop Power = +8dBm   

ii. Unlevel Port power warning might appear if the power span is too wide! 

c. Press Frequency button → CW = 950 MHz 

3. Setup three traces. 

a. Press Display button → Add Trace → New Trace + Window 

b. Measure S11 (mag dB), S21 (mag dB), and S21 (phase) 

4. Press Cal button → Basic Cal   

a. Check ports 1 & 2 

b. Cal kit = select calibration kit (mechanical kit F603FE for this example). 

c. DUT Connector = check appropriate genders for device under test (female for this 

example). 

d. Ensure ports and RF cable connectors are clean. 

e. Use torque specifications for connectors. 

f. Let the cables rest in a “natural” state with no sharp bends during calibration and 

measurement.  Do not handle the cables during calibration! 

5. Cal Type = Enhanced Response 1→2 

a. NOTE:  Depending on cal-kit and the gender that was selected, Cal Type options will be 

limited. 

6. Select “Next”  

a. Warning – to protect equipment, insert a 13 to 20dB attenuator with the proper 

power handling capability during the “thru” calibration.  Possible power into port 2 

> +20dBm. 

b. Connect the appropriate calibration load from kit to the calibration reference plane and 

then press the appropriate tab (open, short, 50Ω load, & thru) 

c. No need to select “isolation” since the noise floor is well below the expected 

measurement results for all S-parameters. 

d. Press Finish tab and Save calibration 

i. Save→State→Save Type→State and Cal Data→Save State as (name file) 

e. Verify calibration  

i. S21 magnitude and phase will display 0dB and 0° across the power sweep. 
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Measuring P1dB GVA-62 low power amplifier 
The following procedure is for measuring compression point and phase linearity of GVA-62 

Evaluation Board.  These two measurements are an indication of the linearity of the DUT and are 

indicators of error vector magnitude (EVM) performance. 

Warning – for this example, to protect equipment, insert a 13 to 20 dB attenuator with 

the proper power handling capability at the output of the DUT.  Maintain the input power 

@ port 2 < +10 dBm. 

1. Setup VNA as described in previous. 

2. Please do not connect DUT just yet! 

3. From above IF BW = 20 kHz, # of points = 201, Power = -10 dBm →+8 dBm, Fc=950 MHz 

4. Measure→ trace 1 = S11(dB), trace 2 = S21 (dB), trace 3 = S21 (phase) 

a. DUT = Mini Circuits GVA-62+ (parameters from data sheet)  

b. V = 5V, I = 81mA  S21 ≈ +15.6 dB, P1 dB  ≈ +19.6 dBm (output compression point) 

c. S11 ≈ -13 dB, S22 ≈ -19 dB, S12 ≈ -21 dB 

5. Press Power button → RF Power Off, ensure it is set to -10 dBm → +8 dBm. 

a. Connect DUT (voltage off) 

b. Apply voltage (for safety, if possible, voltage/current limit power supply)  

c. Turn RF power On. 

d. Set a marker at Pin = -8dBm (this is the reference marker) 

e. Set a second marker at the point where the gain is -Δ1dB from the marker at -8dBm. 

f. This is the output 1dB compression point = Pin + gain (dBm) 

6. Results – see below. 

NOTE:  It is possible that the DUT may have gain expansion, if that is the case, the 

P1dB point is usually measured from the maximum gain point to  -Δ1 dB. 
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Output P1dB = 6.05dBm + 14.24 (+20.29dBm), Phase flatness = Δ2.5° 

 

 

 

 

 

Set-up and Measuring Band Pass Filter 
The following procedure is for measuring  S-parameters of a band pass filter (Mini Circuits VBFZ-

925-S+).  The measurements will be broken up into two sections:  The first is a broad band 

measurement to cover the bandpass and band-rejection response of the filter. The second 

focuses on the Δ3dB bandpass response in which the frequency span will be reduced and 

recalibrate with all other settings unchanged. The procedure will cover a critical aspect of a filter 

which is flatness of the phase linearity or group delay.  This impacts linear frequency modulation 

(LFM) schemes. 

1. Set up VNA as described below. 

2. See section on how to calibrate VNA – “Setup for measuring S-parameters and calibration”. 

3. IF BW = 100 kHz, # of points = 7001, Power = 0 dBm, Start = 100 MHz, Stop = 8000 MHz 

(step size = 1.13 MHz) 

a. Under sampling since step size >> IF BW. 

b. Step size suggest a maximum measurable group delay of 455 nS 

 (GD = 180°/360°*1.13 MHz). 

c. Settings provide approximately 60 dB of dynamic range with smoothing ON-5%. 

4. Perform a full 2-port calibration. 

5. Verify calibration – see section “Verify Calibration”. 

a. Connect RF cables together with the calibration thru adaptor. 

b. Phase (S21/S12) – insertion phase of cal-kit thru adaptor. 

i. F603FE: 820 MHz=-16.25°, 900 MHz=-17.7°, 920MHz=-18.3°, 950 MHz=-18.95°, & 

980 MHz=-19.5° (all approximately  ±0.2°). 

c. Magnitude (S21/S12) should be flat across the band and read very close to 0 dB. 
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d. Magnitude (S11/S22) should be better than <-35 dB across the band. 

e. Results are dependent on the quality of the RF cables, specifically at higher frequencies. 

6. Parameters – see table below (from data sheet VBFZ-925): 

 

Magnitude measurement 
1. Magnitude – Setup for traces 

a. Press Display button → Add Trace → New Trace + Window 

b. Measure magnitude S11, S22, S21 & S12 and scale accordingly. 

c. Turn “Smoothing ON” for S21/S12 measurement if desired. 

i. Connect DUT  

ii. Place markers as needed. 

iii. Results for broad band response – see below. 

2. Change the following frequency span and perform a full 2-port calibration.  This span should 

cover the  -Δ3.0 dB pass band relative to the nominal insertion loss. 

a. IF BW = 100 kHz, # of points = 7001, Power = 0dBm, Start = 650 MHz, Stop = 1350 MHz 

(step size = 100 kHz) 

b. Smoothing = Off (all traces) 

c. Hint – perform a simple response calibration and measure 3 dB points to confirm 

adequate frequency span prior to performing a full calibration. 

3. Verify calibration – see section “Verify Calibration”. 

a. Connect RF cables together with the calibration thru adaptor. 

b. Phase (S21/S12) - insertion phase of cal-kit thru adaptor. 

c. Magnitude (S21/S12) should be flat across the band and read very close to 0 dB. 

d. Magnitude (S11/S22) should be better than <-45 dB across the band. 

4. Magnitude - Setup four traces. 

a. Measure magnitude S11, S22, S21 & S12 and scale accordingly. 

i. Connect DUT  

ii. Place markers at peak and -Δ3dB for S21 and S12 traces. 

iii. Results – see below. 

 

GD and Phase measurement 
1. GD and Phase - Setup two traces. 

a. Delete two traces. 

b. Use Format 2 →unwrap phase (better resolution for phase non-linearity). 

c. Measure phase and group delay S21 or S12 and scale accordingly (reciprocity DUT). 

d. Group delay trace – Smoothing ON @ 5% smoothing percentage . 

e. Place a marker at the minimum GD point and markers at the -Δ3dB points. 

f. Scale = 0.5 nS/div 

g. Adjust “Number of Points” and verify measurement is constant. 

i. If not, recalibrate after the measurement is constant. 

ii. As the number of points is adjusted, an “*” will appear at the bottom of screen. 

iii. C 2-port to C*2-port indicating a change from the calibration parameters. 

iv. GD is a noisy measurement specifically when measuring pico-Seconds. 

 

Phase linearity 

1. Phase Linearity – manually enter delay 

a. Note the minimum delay time on GD trace (smoothing or averaging may help). 

b. Do not change the trace setups from previous measurement – no need to recalibrate. 

c. On existing unwrapped phase trace, change the following: 
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i. Format → phase 

ii. Scale → Electrical Delay – enter delay time from step “a”. 

iii. Electrical Delay for GD trace remains at 0 Sec. 

iv. Velocity factor is not critical for this example. 

v. Scale phase trace.  

NOTE:  This is the non-linear phase response across the pass band – deviation from a constant 

slope.  Notice that it gets worse near the -3dB points, which is common on filters.  Typically, as 

gain/loss changes, there is also a change in phase.  Non-linear phase response may be 

undesirable such as with linear frequency modulated chirps. 

 

Data Sheet 

 

 

Broad Band Magnitude Frequency Response (VBFZ-925-S+) 
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NOTE:  Notice that S21/S12 are symmetrical which is expected; however, S11/S22 are not.  This 

is probably because of an added adaptor.  To verify this, flip the ports and the results should flip.    

 

  

 

3dB Pass Band Magnitude Frequency Response, ≈ 618MHz (VBFZ-925-S+) 

 

 

 

 

Pass band unwrapped phase and group delay (VBFZ-925-S+) 
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Phase linearity (deviation from constant phase slope) and GD 

 

 

Set-up and Measuring RF Splitter/Combiner 
The following procedure is for measuring  S-parameters of an RF splitter/combiner (Mini Circuits 

ZFSC-2-372-S+).  The procedure will cover a critical aspect of a splitter/combiner which is the 

magnitude and phase balance of the ports. Also covered is port - port isolation.  This procedure 

does not cover phase linearity – refer to Filter measurement. 

1. Set up VNA as described below. 

2. See section on how to calibrate VNA – “Setup for measuring S-parameters and calibration”. 

3. IF BW = 100kHz, # of points = 3201, Power = 0 dBm, Start = 800 MHz, Stop = 1000 MHz 

(step size = 62.5 kHz) 

4. Perform a full 2-port calibration. 

5. Verify calibration – see section “Verify Calibration”. 

a. Connect RF cables together with the calibration thru adaptor. 

b. Phase (S21/S12) – insertion phase of cal-kit thru adaptor. 

i. F603FE: 820 MHz=-16.25°, 900 MHz=-17.7°, 920 MHz=-18.3°, 950 MHz=-18.95°, & 

980 MHz=-19.5° (all approximately  ±0.2°). 

c. Magnitude (S21/S12) should be flat across the band and read very close to 0 dB. 

d. Magnitude (S11/S22) should be better than <-45dB across the band. 

6. Parameters – see table below (from data sheet): 

Magnitude, port balance, and isolation measurement 
1. Magnitude S11/S22 – Setup traces 

a. Press Display button → Add Trace → New Trace + Window 

b. Measure magnitude S11 and S22 and  scale accordingly. 

c. Connect VNA to ports S & 1 of DUT. 

i. Terminate port 2 with a load better than -25 dB return loss. 

ii. Place markers as needed and place traces in memory – Math→display “data and 

memory”. 

iii. Connect ports S-2, terminate port 1. 

iv. Results – see below. 
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2. Magnitude and Phase S21/S12– Setup traces 

a. Add two more traces – 4 total 

b. Measure magnitude/phase S21 and S12 and  scale accordingly. 

c. Connect VNA to ports S-1 of DUT. 

i. Terminate port 2 with a load better than -25 dB return loss. 

ii. Place markers as needed and place all traces in memory. 

iii. Connect ports S-2, terminate port 1. 

iv. Results – see below. 

3. Response calibration for magnitude and phase balance. 

a. Connect VNA to ports S-1 of DUT, terminate other port. 

b. Perform a “Response (thru) 1 → 2” calibration. 

c. Place both traces to Memory and display “data and memory”– this is the reference 

display. 

d. Both  traces should display 0 dB and 0°. 

e. Connect VNA to Ports S-2 of DUT, terminate other port. 

f. Results – see below. 

4. Output ports isolation – Magnitude S21 and S12 

a. Perform a full two port calibration as described above or recall saved calibration. 

b. Connect VNA ports to Ports 1-2 of DUT. 

c. Terminate port S with a load better than -25dB return loss. 

d. Results – see below. 

 

 

 

 

 

Data Sheet (RLdb = 20 log[(VSWR-1) / VSWR +1) ]) 
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Return loss – Ports S,1, and 2 (ZFSC-2-372-S+) 

 

 

 

 

 Ports S-1 and S-2 magnitude and phase response (ZFSC-2-372-S+) 
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Ports S-1 and S-2 magnitude and phase balance with “response calibration” (ZFSC-2-372-S+) 

 

 

 

 

Ports 1-2 magnitude isolation (ZFSC-2-372-S+) 
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Set-up and Measuring RF Switch – 3 port measurement 
The following procedure is for measuring  S-parameters of an RF Switch (Mini Circuits MWA2-

50+).  Measurements include port-port isolation, measuring video feed-thru using an oscilloscope, 

and the frequency spectrum under pulse conditions.  The switch is absorptive, meaning that the 

isolated port is terminated into an internal 50Ω load.  This procedure does not cover measuring 

amplitude and phase balance; however, the procedure is covered in the “RF Splitter/Combiner” 

section. 

1. Set up VNA as described below. 

2. See section on how to calibrate VNA – “Setup for measuring S-parameters and calibration”. 

3. IF BW = 100kHz, # of points = 3201, Power = 0dBm, Start = 800MHz, Stop = 1000MHz (step 

size = 62.5 kHz) 

4. Perform a full 3-port calibration (similar to a 2-port) → Basic Cal → Port (check 1,2,&3) 

5. Verify calibration – see section “Verify Calibration”. 

a. Connect RF cables together with the calibration thru adaptor. 

i. Phase (S31/S32/S21) – insertion phase of cal-kit thru adaptor. F603FE: 820MHz=-

16.25°, 900MHz=-17.7°, 920MHz=-18.3°, 950MHz=-18.95°, & 980MHz=-19.5° (all 

approximately  ±0.2°). 

b. Magnitude (S31/S32/S21) should be flat across the band and read very close to 0 dB. 

c. Magnitude (S11/S22/S33) should be better than <-45 dB across the band. 

6. Parameters – see table below (from data sheet): 

 

 

Return Loss and Insertion losses 
1. Magnitude  – Setup three traces (see diagrams below on how to connect DUT). 

a. Press Display button → Add Trace → New Trace + Window 

b. Connect VNA to DUT as follows: 

i. VNA Port 1 – RF in 

ii. VNA Port 2 – RF out 1 

iii. VNA Port 3 – RF out 2 

c. Do not apply any control voltages to C1 or C2 of RF switch, leave floating . 

i. Measure magnitude S11, S22, and S33and  scale accordingly – save measurement. 

ii. Measure magnitude S21, S31, and S32 and  scale accordingly – save measurement. 

iii. Results – see below. 

d. Apply -5V to C1 and Gnd to C2 (RF In → RF Out 1, RF Out 2 internally terminated).   

i. Measure magnitude S11, S22, and S33and  scale accordingly – save measurement. 

ii. Measure magnitude S21, S31, and S32 and  scale accordingly – save measurement. 

iii. Results – see below. 

e. Apply -5V to C2 and Gnd to C1 (RF In → RF Out 2, RF Out 1 internally terminated). 

i. Measure magnitude S11, S22, and S33and  scale accordingly – save measurement. 

ii. Measure magnitude S21, S31, and S32 and  scale accordingly – save measurement. 

iii. Results – see below. 
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Floating control voltages Return loss 

 

 

 

 

 

Insertion losses – control voltages floating 
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Return loss - RF in → RF out 1, RF out 2 terminated (-5V C1, gnd C2) 

 

 

 

 

 

 

Insertion loss S21 – RF in → RF out 1, RF out2 terminated (-5V C1, gnd C2) 
S31 – RF to RF out 2 isolation, S32 – RF out 1 to RF out 2 isolation 
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Return loss - RF in → RF out 2, RF out1 terminated (-5V C2, gnd C1) 

 

 

 

 

 

 

Insertion loss S31 – RF in → RF out 2, RF out1 terminated (-5V C2, gnd C1) 
S31 – RF to RF out 1 isolation , S32 – RF out 1 to RF out 2 isolation 
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Measuring Video feed-thru  
The following procedure is for measuring the “command” feed-thru using an oscilloscope when 

toggling states of an RF switch (Mini Circuits MWA2-50+). 

1. Using a function generator, connect the RF switch as below (see diagram) . 

a. Waveform = Pulsed 

b. Period = 20uS 

c. Pulse width = 5uS 

d. Rise/Fall time = 100nS 

e. Load = Hi Z. 

f. Voltage = -5V/0V. 

2. Terminate RF In with a 50Ω load – connect RF Out 2 to oscilloscope. 

3. Set the oscilloscope to Hi-Z  - save snapshot. 

4. Set the oscilloscope to 50Ω - save snap shot. 

5. Results – see below. 

NOTE:  Notice the difference in video feed-thru amplitude depending on the RF Out 2 termination 

(38mV vs. 4mV).  The rise/fall time of the trigger signal did affect the amplitude of the feed-thru – 

not recorded. 

 

 

RF Out 2 Video Feed-thru (Oscope = HiZ 10 mV / div, 1 uS/div) 
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RF Out 2 Video Feed-thru (Oscope = 50Ω  2 mv/div, 1 uS/div) 

 

 

  

Envelope detection and RF spectrum 
The following procedure is for measuring the envelope and frequency spectrum of a pulsed RF 

signal using the RF switch (Mini Circuits MWA2-50+).   

1. Using a function generator, connect the RF switch as below (see diagram). 

a. Waveform = Pulsed 

b. Period = 1 mS 

c. Pulse width = 1uS & 100 uS 

d. Rise/Fall time = 100 nS 

e. Load = Hi Z. 

f. Voltage = -5V/0V. 

2. Connect RF IN to a RF signal generator via attenuator. 

a. Place a 3dB attenuator at the input to RF IN of the switch (dampens residual voltage 

feed-thru). 

b. Amplitude = +3 dBm 

c. Freq = 1 GHz (CW) 

3. Connect RF Out 2 to a video detector and terminate RF Out 1 (proprietary JRF_Engineering 

detector). 

4. Connect output of video detector to oscilloscope. 

a. Set the oscilloscope to Hi-Z and then 50Ω. 

b. Set pulse width to 1uS and then 100uS - save snapshots. 

5. Results – see below. 
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Pulsed RF envelope Oscope Hi Z (50 mV/div, 100 nS/div) 
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Pulsed RF envelope Oscope 50Ω (5 mV/div, 100 nS/div) 

 

 

 

 

Pulsed RF envelope Oscope Hi Z (50 mV/div, 10 uS/div) 
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Pulsed RF envelope Oscope 50Ω (5 mV/div, 10 uS/div) 

 

1. Connect the output of RF Out 2 to a spectrum analyzer and terminate RF Out 1 (see 

diagram). 

2. Maintain the same configuration on the function generator and RF signal generator as above. 

3. Spectrum analyzer: 

a. Fc = 1 GHz 

b. Span = 20 MHz and 200 kHz 

c. RBW/VBW = 10 kHz and 1 kHZ 

d. Ref Level = 5 dBm 

e. Max Hold 

4. Set function generator pulse width to 100 uS and a period of 1 mS - save snapshots. 

5. Results – see below. 

NOTE:  Notice symmetry, this is an indication that the rise/fall time of the pulsed RF signal are 

equal. The peak power appears to be low, this is because of the RBW, increase the RBW or 

increase the pulse width.  Nulls should appear at frequency points of 1/PW (1/100 uS = 10 kHz). 
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Period = 1 mS, PW = 100 uS, RBW = 10 kHz Span = 20 MHz 

 

Period = 1 mS, PW = 100 uS, RBW = 1 kHz Span 200 KHz 

 

Set-up and Measuring RF Coupler 
The following procedure is for measuring  S-parameters of an RF Coupler (Mini Circuits 

ZGBDC20-372HP+).  Measurements include coupling, isolation, directivity, and coupled phase.  

1. Set up VNA as described below. 

2. See section on how to calibrate VNA – “Setup for measuring S-parameters and calibration”. 

3. IF BW = 100 kHz, # of points = 3201, Power = 0 dBm, Start = 800 MHz, Stop = 1000 MHz 

(step size = 62.5 kHz) 

4. Perform a full 2-port calibration 

5. Verify calibration – see section “Verify Calibration”. 
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a) Connect RF cables together with the calibration thru adaptor. 

b) Phase (S21/S12) should read the insertion phase of the “thru adaptor” included in the 

cal-kit. 

i. F603FE: 820MHz=-16.25°, 900 MHz=-17.7°, 920 MHz=-18.3°, 950 MHz=-18.95°, & 

980 MHz=-19.5° (all approximately  ±0.2°). 

c) Magnitude (S12/S21) should be flat across the band and read very close to 0dB. 

d) Magnitude (S11/S22) should be better than <-45dB across the band. 

6. Parameters – see table below (from data sheet): 

 

 

 

 

Return Loss and Insertion loss 
1. Magnitude  – Setup two traces 

a. Press Display button → Add Trace → New Trace + Window 

b. Connect VNA to DUT as follows: 

i. VNA Port 1 – IN (1) and CPL IN (3) 

ii. VNA Port 2 – OUT (2) and CPL OUT (4) 

c. Terminate the unused ports of DUT with a load better <-25dB return loss.  

i. The load will impact the isolation measurement. 

ii. Example:  load = -20 dB RL, expected coupling = -20dB, the best isolation can be is -

40 dB. 

d. Measure magnitude S11 and S22 and  scale accordingly – save measurement. 

e. Measure magnitude S33 and S44 and  scale accordingly – save measurement. 

f. Measure magnitude S21 and S12 and  scale accordingly – save measurement. 

g. Measure magnitude S43 and S34 and  scale accordingly  – save measurement. 

h. Measure magnitude S31 and S42 and  scale accordingly (coupling)– save measurement. 

i. Measure magnitude S13 and S24 and  scale accordingly (coupling)– save measurement. 

i. If the coupling factor is referenced to the “output port” of the coupler, the insertion loss 

must be included.  See step L.  

j. Measure magnitude S41 & S14 & scale accordingly (isolation/directivity) – save 

measurement. 

k. Measure magnitude S32 & S23 & scale accordingly (isolation/directivity)– save 

measurement. 

i. Isolation(dB) = Directivity(dB) + Coupling(dB) 

l. Measure S21 – coupling referenced to OUT port, nulling OUT to IN losses 

i. Perform a “response” calibration port 1 → 2, OUT to IN. 

ii. Magnitude and phase should be 0dB and 0°. 

iii. Connect VNA port 2 to CPL OUT port of DUT – save measurement. 

iv. This is the coupling and phase referenced to OUT port of DUT. 

v. Coupling’ = Coupling  - Insertion loss (Example: Coupling’ = -20 dB - -1 dB → -19 dB) 

m. Results – see below. 
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S11 and S22 
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S33 and S44 (coupled ports) 

 

 

 

 

S21 and S12 
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S43 and S34 (coupled ports) 

 

 

 

 

IN to CPL IN 
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OUT to CPL OUT 

 

 

 

 

IN to CPL OUT (isolation) 
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OUT to CPL IN (isolation) 

 

 

 

 

S31 (IN to CPL IN) after S21 Response Calibration (IN to OUT nulled) 

Coupling referenced to the OUT port 
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About SIGLENT 

 
SIGLENT is an international high-tech company, concentrating on R&D, 

sales, production and services of electronic test & measurement instruments. 

 

SIGLENT first began developing digital oscilloscopes independently in 2002. 

After more than a decade of continuous development, SIGLENT has 

extended its product line to include digital oscilloscopes, isolated handheld 

oscilloscopes, function/arbitrary waveform generators, RF/MW signal 

generators, spectrum analyzers, vector network analyzers, digital 

multimeters, DC power supplies, electronic loads and other general purpose 

test instrumentation. Since its first oscilloscope was launched in 2005, 

SIGLENT has become the fastest growing manufacturer of digital 

oscilloscopes. We firmly believe that today SIGLENT is the best value in 

electronic test & measurement. 

Headquarters: 

SIGLENT Technologies Co., Ltd 

Add: Bldg No.4 & No.5, Antongda Industrial 

Zone, 3rd Liuxian Road, Bao'an District, 

Shenzhen, 518101, China  

Tel: + 86 755 3688 7876 

Fax: + 86 755 3359 1582 

Email: sales@siglent.com 

Website: int.siglent.com 

 

North America: 

SIGLENT Technologies America, Inc 

6557 Cochran Rd Solon, Ohio 44139 

Tel: 440-398-5800 

Toll Free: 877-515-5551 

Fax: 440-399-1211 

Email: info@siglentna.com 

Website: www.siglentna.com 

 

Europe: 

SIGLENT Technologies Germany GmbH 

Add: Staetzlinger Str.  70 

86165 Augsburg, Germany 

Tel: +49(0)-821-666 0 111 0 

Fax: +49(0)-821-666 0 111 22 

Follow us on
Facebook: SiglentTech


